Use Adobe Edge in Joomla

A multipurpose module, plugin and component

Use Adobe Edge in Joomla

New postby Sergio95810 » Sun Aug 12, 2012 9:23 pm

Hello,

I have searched on internet how to integrate Adobe Edge module (that are HTML5 module with Javascript) in Joomla. I have not found because Adobe Edge is really new and still in the labs stuff of Adobe.
I have to say here that thanks to Jumi, it is posible to use Edge scripts in Joomla.

First, you have to define the path in joomla directory where you want to copy edges stuffs (composed of one includes directory, one images directory and a couple of javascripts - if your edge project is called myproject you will have myproject_edge.js, myporject_edgePreload.js and myproject_edgeActions.js). Let decide that this directory will be a new root directory in joomla that we will call "animation".
Before copying the files, let modify it with a standard text editor this way :
- myproject_edge.js let change the 6th line from var im='images/' to var im='/animation/images/'
- myproject_adgePreload.js change all the aLoader chapter by prefixing all the js scripts by /animation/ (example { load: "/animation/edge_includes/jquery..."). To the same for the Precontent if you have a preloader.
Copy all the files to you animation directory on you server.

In Jumi, create a new jumi object containing (replace de xxxxx by the edge number) :
<!--Adobe Edge Runtime-->
<script type="text/javascript" charset="utf-8" src="/animation/myproject_edgePreload.js"></script>
<style>
.edgeLoad-EDGE-xxxxxxxx { display:none; }
</style>
<!--Adobe Edge Runtime End-->

<div id="body" class="EDGE-xxxxxx">
</div>

Done !
Sergio95810
 
Posts: 1
Joined: Sun Aug 12, 2012 9:01 pm

Re: Use Adobe Edge in Joomla

New postby joomcrafter » Wed Jan 08, 2014 9:00 pm

Hello. I realize this is a long time since you posted, so I will send you a PM if you're not still monitoring this thread.

I tried your method for inserting the Edge code via a Jumi component, but it does not work in my Joomla! 2.5 test site.

I suspect it has something to do with the javascript not running. I examined the headers of the page in question, and there is no reference to a jQuery file at all.

TIA if you could point me in the right direction!
joomcrafter
 
Posts: 6
Joined: Thu Jul 26, 2012 2:01 am


Return to Jumi

Who is online

Users browsing this forum: No registered users and 5 guests

cron