JUMI incompatible with new PHP

A multipurpose module, plugin and component

JUMI incompatible with new PHP

New postby stuffdone » Fri Mar 13, 2015 6:00 pm

Jumi is not compatible with new servers with current PHP installed.

While there is a claim it is Joomla 3x compatible that is only half the equation.

I have many joomla sites with jumi and that extension is causing rapid growth of error log files due to not being compatible with PHP any longer. It works but my customer's disk quotas are being consumed by error logs as a result.

I don't want to have to write or edit a custom php.ini file for 60 domains and delete 120 log files to solve some one else's problem in coding. This will be an all-day fix for something that might break again in the future if the extension is not kept up to date with auto-update ability and recent PHP versions.

Does anyone know of an alternative to JUMI?
stuffdone
 
Posts: 2
Joined: Fri Mar 13, 2015 5:46 pm

Re: JUMI incompatible with new PHP

New postby sargbah84 » Wed Mar 25, 2015 8:22 pm

I'm having the same issue too. I installed Jumi on my joomla 3 site that is installed on my WAMP server with the latest version of php and it is displaying lot of php errors. I really don't know how to fix php errors so i don't know where to edit. This Jumi component is not fully compatible with Joomla 3, I don't know why they say that. I love this plugin. It work on my joomla 2.5 websites hosted on my remote server but can not get it on work on a server that has the latest php version. They really need to find solution to their codes.
sargbah84
 
Posts: 2
Joined: Wed Jan 28, 2015 10:52 pm

Re: JUMI incompatible with new PHP

New postby stuffdone » Wed Mar 25, 2015 11:45 pm

I think some developers take short cuts testing and don't use or don't have access to servers with the most recent releases of the essentials like Apache, PHP, MySQL etc. Shame they advertise compatibility when it is no more than "partial" compatibility without being able to clarify the faults and how to get around them.

I had to disable error reporting which I don't like because it will also block reports of something else I really should know about.
stuffdone
 
Posts: 2
Joined: Fri Mar 13, 2015 5:46 pm

Re: JUMI incompatible with new PHP

New postby Nitrofish » Sun Mar 29, 2015 7:29 am

None of you mentioned the version of PHP you are talking about. I am getting an error with Jumi on occasion, but not sure if it is related to this. I am running PHP 5.3.3 and I get the error

Catchable fatal error: Object of class stdClass could not be converted to string in /var/www/vhosts/XXXXXXXX.com/httpdocs/libraries/joomla/application/module/helper.php on line 174

The error does not occur every time. It is sporadic, but very annoying since it is supposed to display an important part of my website on the main page. If you refresh the page after the error is displayed, it displays normally.

Anybody have any idea what's going on with this? I would appreciate any input.
Nitrofish
 
Posts: 1
Joined: Sun Mar 29, 2015 7:21 am


Return to Jumi

Who is online

Users browsing this forum: No registered users and 5 guests

cron